[ovs-git] Open vSwitch: doc: Make explicit that ovs-vswitchd is the preferred switch. (master)

dev at openvswitch.org dev at openvswitch.org
Thu Jul 15 22:09:43 UTC 2010


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  ac7f2d4bb4a92a021553714d1a44c1c62c1817db (commit)
       via  aebdcb93e0f81d6e6a910ffdfa56ba10f2918afe (commit)
       via  1cb8b59f8ca07d4bd3c0fe3a0608d7a8fca6b08f (commit)
       via  27b6cec086eebdd34bc8526901ea6b2a52119f17 (commit)
       via  2848cb494620a13a64a3f862380d709c5977cecb (commit)
       via  f9764f6e911ab3b034b3f390f8303ce1396a4dd8 (commit)
       via  fceb2a5bb2063023777fc75c68a2670b5169fa13 (commit)
       via  10d3515aa4fc0d338df28d2760fae264c0cea40a (commit)
       via  1336993ca480cf647dc0f87c06ac51ec4175a361 (commit)
      from  4f1361e8572832bcd5fa52bc0ec66234b49ac777 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit ac7f2d4bb4a92a021553714d1a44c1c62c1817db
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=ac7f2d4bb4a92a021553714d1a44c1c62c1817db
Author: Jesse Gross <jesse at nicira.com>
		
doc: Make explicit that ovs-vswitchd is the preferred switch.
		
Many people who are looking for an OpenFlow switch assume that
the only way to do it is using ovs-openflowd.  Sometimes they also
run ovs-vswitchd at the same time.  Try to clarify that neither
of these are necessary and ovs-vswitchd can handle OpenFlow by
itself and is the preferred method of doing so.


commit aebdcb93e0f81d6e6a910ffdfa56ba10f2918afe
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=aebdcb93e0f81d6e6a910ffdfa56ba10f2918afe
Author: Jesse Gross <jesse at nicira.com>
		
datapath: Don't update flow key when applying actions.
		
Currently the flow key is updated to match an action that is applied
to a packet but these field are never looked at again.  Not only is
this a waste of time it also makes optimizations involving caching
the flow key more difficult.


commit 1cb8b59f8ca07d4bd3c0fe3a0608d7a8fca6b08f
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=1cb8b59f8ca07d4bd3c0fe3a0608d7a8fca6b08f
Author: Jesse Gross <jesse at nicira.com>
		
datapath: Don't set tunnel_id in a function.
		
We don't need a function to set a variable.  In practice it will
almost certainly get inlined but this makes it easier to read.


commit 27b6cec086eebdd34bc8526901ea6b2a52119f17
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=27b6cec086eebdd34bc8526901ea6b2a52119f17
Author: Jesse Gross <jesse at nicira.com>
		
gre: Use struct for parsing GRE header.
		
GRE is a somewhat annoying protocol because the header is variable
length.  However, it does have a few fields that are always present
so we can make the parsing seem less magical by using a struct for
those fields instead of building it up field by field.


commit 2848cb494620a13a64a3f862380d709c5977cecb
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=2848cb494620a13a64a3f862380d709c5977cecb
Author: Jesse Gross <jesse at nicira.com>
		
gre: Wait for an RCU grace period before freeing port.
		
We currently remove ports from the GRE hash table and then immediately
free the ports.  Since received packets could be using that port this
can lead to a crash (the port has already been detached from the
datapath so this can't happen for transmitted packets).  As a result
we need to wait for an RCU grace period to elapse before actually
freeing the port.

In an ideal world we would actually remove the port from the hash
table in a hypothetical gre_detach() function since this is one of
the purposes of detaching.  However, we also use the hash table to
look for collisions in the lookup criteria and don't want to allow
two identical ports to exist.  It doesn't matter though because we
aren't blocking on the freeing of resources.


commit f9764f6e911ab3b034b3f390f8303ce1396a4dd8
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=f9764f6e911ab3b034b3f390f8303ce1396a4dd8
Author: Jesse Gross <jesse at nicira.com>
		
vport: Use DEFINE_PER_CPU instead of dynamically allocating loop counter.
		
DEFINE_PER_CPU is simpler and faster than alloc_percpu() so use it
for the loop counter, which is already statically defined.


commit fceb2a5bb2063023777fc75c68a2670b5169fa13
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=fceb2a5bb2063023777fc75c68a2670b5169fa13
Author: Jesse Gross <jesse at nicira.com>
		
datapath: Put return type on same line as arguments for functions.
		
In some places we would put the return type on the same line as
the rest of the function definition and other places we wouldn't.
Reformat everything to match kernel style.


commit 10d3515aa4fc0d338df28d2760fae264c0cea40a
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=10d3515aa4fc0d338df28d2760fae264c0cea40a
Author: Jesse Gross <jesse at nicira.com>
		
vport: Use EBUSY to represent already attached device.
		
We currently use EEXIST to represent both a device that is already
attached and for GRE devices that are the same as another one.
Instead use EBUSY for already attached devices to disambiguate the
two situations.


commit 1336993ca480cf647dc0f87c06ac51ec4175a361
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=1336993ca480cf647dc0f87c06ac51ec4175a361
Author: Jesse Gross <jesse at nicira.com>
		
datapath: Make checksum offsets unsigned.
		
The offsets for checksum offsets should always be positive so make
that explicit by using unsigned ints.  This helps bug checks that
test if the offsets are greater than their upper limits.


-----------------------------------------------------------------------

Summary of changes:
 INSTALL.OpenFlow              |    8 +-
 datapath/actions.c            |   78 ++++++------------
 datapath/actions.h            |    6 +-
 datapath/brcompat.c           |   36 ++++-----
 datapath/datapath.c           |   46 ++++------
 datapath/table.c              |    2 +-
 datapath/vport-generic.c      |   12 +--
 datapath/vport-gre.c          |  184 ++++++++++++++++++-----------------------
 datapath/vport-internal_dev.c |   25 ++----
 datapath/vport-netdev.c       |   64 +++++---------
 datapath/vport-patch.c        |   58 +++++---------
 datapath/vport.c              |  161 ++++++++++++------------------------
 datapath/vport.h              |    6 +-
 lib/dpif-netdev.c             |   45 +++-------
 lib/netdev-gre.c              |    2 +-
 lib/netdev-patch.c            |    2 +-
 16 files changed, 270 insertions(+), 465 deletions(-)


hooks/post-receive
-- 
Open vSwitch




More information about the git mailing list