[ovs-git] Open vSwitch: ofproto: Factor out code from do_xlate_actions() into new function. (master)

dev at openvswitch.org dev at openvswitch.org
Wed Nov 10 17:47:52 UTC 2010


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  350a665f37e45bd8f182e0bbea07b83a054ddc7e (commit)
       via  f1defbf96df61a1fce8ec8ca63a56018bff4c940 (commit)
       via  ac51afaf4c98fc275769afa412e68eb2df41e059 (commit)
       via  09246b99d1601e2ba7ff85bb26f9b0235632a76d (commit)
       via  734bbeb479093f367f025a2298a4e70cb6015998 (commit)
       via  06a5e131455621cd1319d9e3fb1bc29f24cd0719 (commit)
      from  ac387ef5ce7115f9539104011f0409eb6a1bbe99 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 350a665f37e45bd8f182e0bbea07b83a054ddc7e
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=350a665f37e45bd8f182e0bbea07b83a054ddc7e
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Factor out code from do_xlate_actions() into new function.
		
This helper will be useful elsewhere in upcoming commits.


commit f1defbf96df61a1fce8ec8ca63a56018bff4c940
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=f1defbf96df61a1fce8ec8ca63a56018bff4c940
Author: Ben Pfaff <blp at nicira.com>
		
ofp-util: Make validate_actions() take a struct flow *.
		
The upcoming support for actions on registers will require the flow to
validate actions, so this commit adds the parameter in advance.  It is
not yet used.


commit ac51afaf4c98fc275769afa412e68eb2df41e059
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=ac51afaf4c98fc275769afa412e68eb2df41e059
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Refactor handle_packet_out().
		
An upcoming commit will require the flow to be passed in as part of
OpenFlow action validation, but handle_packet_out() has until now been
structured to make this difficult.  This commit refactors it to better
suit this purpose.


commit 09246b99d1601e2ba7ff85bb26f9b0235632a76d
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=09246b99d1601e2ba7ff85bb26f9b0235632a76d
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Implement Nicira Extended Match flexible flow match (NXM).
		


commit 734bbeb479093f367f025a2298a4e70cb6015998
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=734bbeb479093f367f025a2298a4e70cb6015998
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Fix type of 'out_port' parameter to query_aggregate_stats().
		
Reported-by: Justin Pettit <jpettit at nicira.com>


commit 06a5e131455621cd1319d9e3fb1bc29f24cd0719
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=06a5e131455621cd1319d9e3fb1bc29f24cd0719
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Rename *_stats_reply() functions for clarity.
		
Suggested-by: Justin Pettit <jpettit at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 include/openflow/nicira-ext.h |  612 ++++++++++++++++++++++++++++++++++-
 lib/automake.mk               |    2 +
 lib/nx-match.c                |  709 +++++++++++++++++++++++++++++++++++++++++
 lib/nx-match.def              |   43 +++
 lib/nx-match.h                |   65 ++++
 lib/ofp-util.c                |   46 +---
 lib/ofp-util.h                |    4 +-
 lib/util.c                    |    5 +-
 lib/vlog-modules.def          |    1 +
 ofproto/ofproto.c             |  389 ++++++++++++++++++++---
 tests/ovs-ofctl.at            |  197 ++++++++++++
 utilities/ovs-ofctl.c         |   73 ++++-
 12 files changed, 2036 insertions(+), 110 deletions(-)
 create mode 100644 lib/nx-match.c
 create mode 100644 lib/nx-match.def
 create mode 100644 lib/nx-match.h


hooks/post-receive
-- 
Open vSwitch




More information about the git mailing list