[ovs-git] Open vSwitch: New action NXAST_RESUBMIT_TABLE. (master)

dev at openvswitch.org dev at openvswitch.org
Tue Aug 9 16:24:33 UTC 2011


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  299016266ed13376a7d671f66d4e0181b41098e3 (commit)
       via  0697b5c3c9954057028f406757c4fd0208b929b9 (commit)
       via  b772ded808ccc1b3cce2c10377a35637b1beb28c (commit)
       via  13521ff59379b6a7a91be18ce8d903cd698694b3 (commit)
       via  073e2a6f2383cf7c17f78b8fa29e6e5293f60ba0 (commit)
       via  79feb7dfc714780ba86de73d42fe366e45e22b05 (commit)
       via  876b0e1c74a43c4edf261e3ca571a440d01b0b4c (commit)
       via  3bffc610fa3ae08fa837f6bd0bf7a2deebdd0970 (commit)
       via  6adf1730c8e21a653faf1d614fdddb2cd7825670 (commit)
      from  18812dff32ce650440b9f1eac1bb00afe08c621a (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 299016266ed13376a7d671f66d4e0181b41098e3
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=299016266ed13376a7d671f66d4e0181b41098e3
Author: Ben Pfaff <blp at nicira.com>
		
New action NXAST_RESUBMIT_TABLE.
		
This makes multiple table support in ofproto-dpif useful, by allowing
resubmits into tables other than 0.


commit 0697b5c3c9954057028f406757c4fd0208b929b9
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=0697b5c3c9954057028f406757c4fd0208b929b9
Author: Ben Pfaff <blp at nicira.com>
		
ofproto-dpif: Add multiple table support.
		
Tables other than 0 can be modified and dumped, but they are not yet useful
because actions and flow table lookups never use them.


commit b772ded808ccc1b3cce2c10377a35637b1beb28c
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=b772ded808ccc1b3cce2c10377a35637b1beb28c
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: New helper macro OFPROTO_FOR_EACH_TABLE.
		
In my opinion this makes the code slightly easier to read and write.


commit 13521ff59379b6a7a91be18ce8d903cd698694b3
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=13521ff59379b6a7a91be18ce8d903cd698694b3
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Allow ->rule_choose_table() to be NULL regardless of table count.
		
In the upcoming software switch implementation of multiple tables, there is
no reason to prefer one table over another, so we always put rules into
table 0 by default.  This commit allows this to be done simply by
specifying NULL as ->rule_choose_table().


commit 073e2a6f2383cf7c17f78b8fa29e6e5293f60ba0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=073e2a6f2383cf7c17f78b8fa29e6e5293f60ba0
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Make ->construct() and ->destruct() more symmetrical.
		
The ofproto_provider's ->construct() was required to allocate and
initialize the flow tables, but ->destruct() was not allowed to
uninitialize and free them.  This arrangement is oddly asymmetrical (and
undocumented), so this commit changes the code so that the client is
responsible for both allocation and freeing.

Reported-by: Hao Zheng <hzheng at nicira.com>
CC: Hao Zheng <hzheng at nicira.com>


commit 79feb7dfc714780ba86de73d42fe366e45e22b05
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=79feb7dfc714780ba86de73d42fe366e45e22b05
Author: Ben Pfaff <blp at nicira.com>
		
ofproto-dpif: Fix pointer arithmetic on null pointer.
		
rule_dpif_lookup() can return a null pointer as 'rule' so we shouldn't
try to calculate '&rule->up' before it's been found to be nonnull.

This doesn't appear to fix a real bug because 'up' is the first member
of 'rule' so when rule is NULL then &rule->up is also NULL.

Reported-by:  Ethan Jackson <ethan at nicira.com>


commit 876b0e1c74a43c4edf261e3ca571a440d01b0b4c
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=876b0e1c74a43c4edf261e3ca571a440d01b0b4c
Author: Ben Pfaff <blp at nicira.com>
		
ofproto-dpif: Make ofproto/trace accept an odp_flow in place of a packet.
		
It's often easier to get a flow than it is to get a packet.  For example,
"ovs-dpctl dump-flows" prints flows, but it doesn't print any of the
packets in those flows.  It is also easier to construct a flow by hand than
it is to construct packet bytes.

This commit, therefore, makes ofproto/trace accept a flow specification in
place of packet data.  In a few cases a flow by itself is not sufficient
to determine what would happen to a packet, so in those cases the command
prints a message to that effect.

An upcoming commit will also start using this feature to unit-test action
translation in ofproto-dpif.

Suggested-by: Reid Price <reid at nicira.com>


commit 3bffc610fa3ae08fa837f6bd0bf7a2deebdd0970
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=3bffc610fa3ae08fa837f6bd0bf7a2deebdd0970
Author: Ben Pfaff <blp at nicira.com>
		
odp-util: New function odp_flow_key_from_string().
		
This will be used in upcoming commits.


commit 6adf1730c8e21a653faf1d614fdddb2cd7825670
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=6adf1730c8e21a653faf1d614fdddb2cd7825670
Author: Ben Pfaff <blp at nicira.com>
		
odp-util: Format VLAN headers more like other headers in ODP flow output.
		
The rest of the headers all follow the form "header(value)" or
"header(key1=value1,key2=value2,...)" but VLAN headers left out the "="
characters.  This adds them in for consistency.


-----------------------------------------------------------------------

Summary of changes:
 NEWS                          |    6 +
 include/openflow/nicira-ext.h |   52 +++++--
 lib/odp-util.c                |  309 ++++++++++++++++++++++++++++++++++++++++-
 lib/odp-util.h                |    1 +
 lib/ofp-parse.c               |   39 +++++-
 lib/ofp-print.c               |   13 ++
 lib/ofp-util.c                |   15 ++
 lib/ofp-util.h                |    1 +
 lib/packets.h                 |   33 +++++
 ofproto/ofproto-dpif.c        |  200 ++++++++++++++++++---------
 ofproto/ofproto-provider.h    |   50 ++++---
 ofproto/ofproto-unixctl.man   |   25 ++++
 ofproto/ofproto.c             |   27 +++--
 tests/automake.mk             |    8 +
 tests/odp.at                  |   40 ++++++
 tests/ofproto-dpif.at         |   19 +++
 tests/ofproto.at              |   20 +--
 tests/ovs-ofctl.at            |    3 +
 tests/test-odp.c              |   85 +++++++++++
 tests/testsuite.at            |    2 +
 utilities/ovs-ofctl.8.in      |   14 ++-
 21 files changed, 832 insertions(+), 130 deletions(-)
 create mode 100644 tests/odp.at
 create mode 100644 tests/ofproto-dpif.at
 create mode 100644 tests/test-odp.c


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list