[ovs-git] Open vSwitch: ovs-brcompatd: Fix uninitialized br_vlan variable in handle_fdb_query_cmd(). (master)

dev at openvswitch.org dev at openvswitch.org
Wed Jun 8 21:09:25 UTC 2011


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  9cb8877cf7d1d86101a8f27829ad47ea0c8b1fe5 (commit)
       via  28bad4735cf1fda0e2064a3128577f3a58d88e8a (commit)
       via  5f4d087c768fb88ebca05b5f5b6dee59cf63017b (commit)
      from  0b813a372f67858e1422a832cc922f10d5149f93 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 9cb8877cf7d1d86101a8f27829ad47ea0c8b1fe5
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=9cb8877cf7d1d86101a8f27829ad47ea0c8b1fe5
Author: Ben Pfaff <blp at nicira.com>
		
ovs-brcompatd: Fix uninitialized br_vlan variable in handle_fdb_query_cmd().
		
Reported-by: Jesse Gross <jesse at nicira.com>
Tested-by: Jesse Gross <jesse at nicira.com>


commit 28bad4735cf1fda0e2064a3128577f3a58d88e8a
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=28bad4735cf1fda0e2064a3128577f3a58d88e8a
Author: Jesse Gross <jesse at nicira.com>
		
datapath: Remove redundant nw_ prefix from fields in flow key.
		
The fields of the kernel flow key are now grouped by protocol rather
than using generic names.  The containing structures describe the
category, so it is no longer necessary to use prefixes.  Most of
these prefixes have been removed but nw_proto and nw_tos have
retained them.  This renames the fields for consistency and brevity.

Signed-off-by: Jesse Gross <jesse at nicira.com>
Acked-by: Ben Pfaff <blp at nicira.com>


commit 5f4d087c768fb88ebca05b5f5b6dee59cf63017b
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=5f4d087c768fb88ebca05b5f5b6dee59cf63017b
Author: Jesse Gross <jesse at nicira.com>
		
datapath: IP fragments should include L4 header in flow length.
		
If we can't parse a header because it is invalid or not present due to
fragmentation, we still need to include the length of that header when
comparing the flow key.  The value of the field will be zero to
indicate that header was not present, rather than effectively
wildcarding the value.  However, this was not done with fragments on
flow extract but is effectively done on flow setup.  Since the flow
length also changes the hash, it caused all fragments to miss the
hash table and be sent to useerspace.

Reported-by: Ben Pfaff <blp at nicira.com>
Signed-off-by: Jesse Gross <jesse at nicira.com>
Tested-by: Ben Pfaff <blp at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 datapath/actions.c       |    2 +-
 datapath/flow.c          |  136 +++++++++++++++++++++++-----------------------
 datapath/flow.h          |    4 +-
 vswitchd/ovs-brcompatd.c |   16 ++++--
 4 files changed, 81 insertions(+), 77 deletions(-)


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list