[ovs-git] Open vSwitch: ofp-parse: Ignore extra fields produced by dump-flows. (master)

dev at openvswitch.org dev at openvswitch.org
Tue Jun 14 18:25:06 UTC 2011


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  2c6d841118a6b14cc5b03fc3b549143a6b7ce143 (commit)
       via  e896c2d42dbb84d1e29504b0b1ed5449f007dea5 (commit)
       via  33d8c6b4128a471db620ca2747973a88af87fb32 (commit)
       via  c168dcc8f7b87579ac6c6a5d0e133377f41cb9f0 (commit)
       via  5e9d0469fcaa30f4de0209392a1329b4c52d8d63 (commit)
       via  7ee20df120d4d56df894abc00a60fe1bc43a058d (commit)
       via  9ed18e4635439cf6cf57a47e3d52b30fce235a70 (commit)
       via  18ddadc2e96279c69b1960af57da7af9332fbb21 (commit)
       via  1be5ff7596ab018eb0491176af493d8c51cf1cc8 (commit)
       via  57452fdcfb64aca9d110fca0736f6c9587d282f1 (commit)
       via  1006cda6d4c36f4e10cab9714d4d625e141a4cad (commit)
       via  349adfb29c9654a8f94d3088028dbde89c6523cc (commit)
       via  76c93b227414f893f54c5ec52155471601713fe0 (commit)
       via  63f2140a553dbbda9f19019a03abb088c7e7fa29 (commit)
       via  675baf0cdf570ca7c979a5bd18a62d230fd91632 (commit)
       via  2a1c0549a3bfd9ef8528ebf7f34fec07ec509e11 (commit)
       via  03cd34939e0f90fab30daf74034de0fbd1af17ec (commit)
       via  28c8bad14f17fea722632e6483e61c80a1b9a8e0 (commit)
       via  45984c6a9280a8074c5add3bf1ef3d53eff44444 (commit)
      from  b6466afa85a9960f9424089f41c1a6e14009c994 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 2c6d841118a6b14cc5b03fc3b549143a6b7ce143
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=2c6d841118a6b14cc5b03fc3b549143a6b7ce143
Author: Ben Pfaff <blp at nicira.com>
		
ofp-parse: Ignore extra fields produced by dump-flows.
		
It's reasonable to want to dump a flow table with "dump-flows" and then
later use that output as input to other commands that read flows, but until
now that hasn't been directly possible because "dump-flows" adds extra
fields that other commands reject on input.  This changes the flow parser
to just ignore those extra fields.


commit e896c2d42dbb84d1e29504b0b1ed5449f007dea5
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=e896c2d42dbb84d1e29504b0b1ed5449f007dea5
Author: Ben Pfaff <blp at nicira.com>
		
ofp-print: Change "table_id" to "table" in flow_mod and flow_stats.
		
Flow dumps printed the OpenFlow table ID under the name "table_id", but
the flow parser only accepted "table".  This makes them consistent by
changing the output.  (Another alternative would be to change the accepted
input name.)


commit 33d8c6b4128a471db620ca2747973a88af87fb32
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=33d8c6b4128a471db620ca2747973a88af87fb32
Author: Ben Pfaff <blp at nicira.com>
		
ofp-parse: Add support for vlan_tci field.
		
Until now, the flow parser has supported dl_vlan and dl_vlan_pcp but not
the fully maskable vlan_tci that NXM allows.  This adds that support.


commit c168dcc8f7b87579ac6c6a5d0e133377f41cb9f0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=c168dcc8f7b87579ac6c6a5d0e133377f41cb9f0
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Add simple tests for dumping aggregates and for OpenFlow 1.0.
		
We had no tests that exercised OFPST_AGGREGATE or NXST_AGGREGATE.  At one
point in development I screwed up aggregate stats badly enough that they
caused an immediate and reproducible segfault, which this simple test would
have caught.

Also, it's best to test everything in both NXM and OpenFlow 1.0 flow
formats, since they have slightly different code.


commit 5e9d0469fcaa30f4de0209392a1329b4c52d8d63
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=5e9d0469fcaa30f4de0209392a1329b4c52d8d63
Author: Ben Pfaff <blp at nicira.com>
		
Define UINT64_MAX as "unknown" in Open vSwitch specific interfaces.
		
Some hardware supports reporting packet or byte counters but not both, so
OVS has to be prepared for that.

Suggested-by: Justin Pettit <jpettit at nicira.com>


commit 7ee20df120d4d56df894abc00a60fe1bc43a058d
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=7ee20df120d4d56df894abc00a60fe1bc43a058d
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Implement asynchronous OFPT_FLOW_MOD commands.
		
Some switching hardware takes a very long time to update its forwarding
rules, up to hundreds of milliseconds.  It is undesirable for Open
vSwitch to block waiting this long for individual OpenFlow flow table
modification commands to complete.  This commit enables ofproto to queue
up any number of independent flow table operations with asynchronous
completion.

I tested earlier versions of this commit using the "ofproto/clog" and
"ofproto/unclog" commands that it implements in the software switch
implementation.  I have not tested the current version very much at all.

CC: Casey Barker <crbarker at google.com>
CC: Rajiv Ramanathan <rajivr at google.com>


commit 9ed18e4635439cf6cf57a47e3d52b30fce235a70
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=9ed18e4635439cf6cf57a47e3d52b30fce235a70
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Collect all rules for an OpenFlow request before acting on any.
		
An upcoming commit adds support for asynchronous flow table modification.
In an attempt to ensure that the software and hardware flow tables are
properly in sync, that commit limits any given rule to a single outstanding
operation at a time.  It does so by figuring out all of the rules that an
OpenFlow request will affect before modifying any of them, and then
deferring the request if it will affect any rules that have ongoing
operations.  This commit is a step in that direction.


commit 18ddadc2e96279c69b1960af57da7af9332fbb21
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=18ddadc2e96279c69b1960af57da7af9332fbb21
Author: Ben Pfaff <blp at nicira.com>
		
ofp-util: New functions ofputil_actions_equal(), ofputil_actions_clone().
		
I found that introducing these helper functions provided a very modest
increase in readability.


commit 1be5ff7596ab018eb0491176af493d8c51cf1cc8
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=1be5ff7596ab018eb0491176af493d8c51cf1cc8
Author: Ben Pfaff <blp at nicira.com>
		
connmgr: New function ofconn_send_error().
		
An upcoming commit will sometimes make connmgr responsible for sending
error replies, so it's reasonable for it to have a function to do that.


commit 57452fdcfb64aca9d110fca0736f6c9587d282f1
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=57452fdcfb64aca9d110fca0736f6c9587d282f1
Author: Ben Pfaff <blp at nicira.com>
		
classifier: New function cls_rule_hash().
		
An upcoming commit will introduce the first use.


commit 1006cda6d4c36f4e10cab9714d4d625e141a4cad
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=1006cda6d4c36f4e10cab9714d4d625e141a4cad
Author: Ben Pfaff <blp at nicira.com>
		
flow: Give flow_wildcards_hash() a 'basis' parameter.
		
An upcoming commit will add more interesting uses.


commit 349adfb29c9654a8f94d3088028dbde89c6523cc
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=349adfb29c9654a8f94d3088028dbde89c6523cc
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Better abstract flow stats encoding.
		


commit 76c93b227414f893f54c5ec52155471601713fe0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=76c93b227414f893f54c5ec52155471601713fe0
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Better abstract aggregate stats encoding and decoding.
		


commit 63f2140a553dbbda9f19019a03abb088c7e7fa29
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=63f2140a553dbbda9f19019a03abb088c7e7fa29
Author: Ben Pfaff <blp at nicira.com>
		
openflow: Make stats replies more like other OpenFlow messages.
		


commit 675baf0cdf570ca7c979a5bd18a62d230fd91632
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=675baf0cdf570ca7c979a5bd18a62d230fd91632
Author: Ben Pfaff <blp at nicira.com>
		
nicira-ext: Separate nx_aggregate_stats_reply from ofp_aggregate_stats_reply.
		
An upcoming patch will make stats messages much more like other messages,
in that their structures will include all of the headers.  This means that
struct ofp_aggregate_stats_reply will no longer be appropriate as a
member of struct nx_aggregate_stats_reply, because it will then include
those additional header members.

Also, struct nx_aggregate_stats_reply doesn't need to use the special
ovs_32aligned_be64 type, since its 64-bit members are correctly aligned,
which is another reasonable reason to keep it separate.


commit 2a1c0549a3bfd9ef8528ebf7f34fec07ec509e11
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=2a1c0549a3bfd9ef8528ebf7f34fec07ec509e11
Author: Ben Pfaff <blp at nicira.com>
		
openflow: Merge ofp_flow_stats_request and ofp_aggregate_stats_request.
		


commit 03cd34939e0f90fab30daf74034de0fbd1af17ec
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=03cd34939e0f90fab30daf74034de0fbd1af17ec
Author: Ben Pfaff <blp at nicira.com>
		
openflow: Remove 'body' member from struct ofp_stats_msg.
		
This member does not actually help with anything.


commit 28c8bad14f17fea722632e6483e61c80a1b9a8e0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=28c8bad14f17fea722632e6483e61c80a1b9a8e0
Author: Ben Pfaff <blp at nicira.com>
		
openflow: Merge ofp_stats_request and ofp_stats_reply.
		
These structures for OpenFlow stats requests and replies have identical
memebers, but until now they have been separate structures.  Since in some
cases we actually want to treat both of them the same way, this has led
to various kinds of awkwardness.  This commit merges them into a new
"struct ofp_stats_msg" and fixes up the users.


commit 45984c6a9280a8074c5add3bf1ef3d53eff44444
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=45984c6a9280a8074c5add3bf1ef3d53eff44444
Author: Ben Pfaff <blp at nicira.com>
		
ofproto: Correctly fill in table_id in NXST_FLOW replies.
		


-----------------------------------------------------------------------

Summary of changes:
 include/openflow/nicira-ext.h |   20 +-
 include/openflow/openflow.h   |   93 ++--
 lib/classifier.c              |   14 +-
 lib/classifier.h              |    1 +
 lib/flow.c                    |    4 +-
 lib/flow.h                    |    2 +-
 lib/ofp-parse.c               |   42 ++
 lib/ofp-print.c               |   53 +-
 lib/ofp-util.c                |  341 ++++++++--
 lib/ofp-util.h                |   39 +-
 lib/ofpbuf.c                  |   10 +
 lib/ofpbuf.h                  |    1 +
 lib/vconn.h                   |    2 +-
 ofproto/connmgr.c             |  186 +++++-
 ofproto/connmgr.h             |   16 +-
 ofproto/in-band.c             |  296 ++++-----
 ofproto/in-band.h             |    1 -
 ofproto/ofproto-dpif.c        |  123 +++-
 ofproto/ofproto.c             | 1420 ++++++++++++++++++++++-------------------
 ofproto/private.h             |  208 +++++--
 tests/ofp-print.at            |   38 +-
 tests/ofproto.at              |   29 +-
 tests/ovs-ofctl.at            |   10 +-
 utilities/ovs-ofctl.8.in      |   42 ++
 utilities/ovs-ofctl.c         |   19 +-
 25 files changed, 1883 insertions(+), 1127 deletions(-)


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list