[ovs-git] Open vSwitch: flow: Enable matching on new field 'pkt_mark'. (master)

dev at openvswitch.org dev at openvswitch.org
Tue Aug 13 21:43:08 UTC 2013


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  ac923e910e15e934137b9f12997d153c83292edf (commit)
       via  ed2e72459317c689c46d3f1d279945485ff34fda (commit)
       via  62a7cc71f56ff6a2e943db3d1db238bf7ecd8bc9 (commit)
       via  1362e248d68a8b7de3e6ec3689245e4dc882292b (commit)
      from  15d0658c6913092adfa9c0ce001ec21e94ff67ba (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit ac923e910e15e934137b9f12997d153c83292edf
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=ac923e910e15e934137b9f12997d153c83292edf
Author: Jesse Gross <jesse at nicira.com>
		
flow: Enable matching on new field 'pkt_mark'.
		
The Linux kernel datapath enables matching and setting the skb mark
but this functionality is currently used only internally by
ovs-vswitchd. This exposes it through NXM to enable external
controllers to interact with other kernel subsystems. Although this
is simply exporting the skb mark, the intention is that this is a
platform independent mechanism to access some system metadata and
therefore may have different implementations on various systems.

Bug #17855

Signed-off-by: Jesse Gross <jesse at nicira.com>
Acked-by: Andy Zhou <azhou at nicira.com>


commit ed2e72459317c689c46d3f1d279945485ff34fda
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=ed2e72459317c689c46d3f1d279945485ff34fda
Author: Jesse Gross <jesse at nicira.com>
		
tunnel: Clear IPSEC_MARK on input rather than output.
		
Currently we remove the IPSEC_MARK flag from all packets that are
egressing on non-tunnel ports. However, this behavior is confusing
if we allow OpenFlow controllers to match and set the pkt_mark field
because the tunnel behavior applies even on non-tunnel ports.

This instead clears the mark on tunnel input which should have the
same effect for tunnel ports. However, on non-tunnel traffic (or
even for traffic entering on a tunnel port but leaving on a non-
tunnel port) it allows the mark to pass through without change.

Signed-off-by: Jesse Gross <jesse at nicira.com>
Acked-by: Andy Zhou <azhou at nicira.com>


commit 62a7cc71f56ff6a2e943db3d1db238bf7ecd8bc9
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=62a7cc71f56ff6a2e943db3d1db238bf7ecd8bc9
Author: Jesse Gross <jesse at nicira.com>
		
tunnel: Consolidate action code for tunnel port receive.
		
There are a couple of operations that are related to receiving a
packet on a tunnel port but that affect the actions and therefore
need to be performed on the output path. This adds a new hook to
do this and consolidates the existing code there.

Signed-off-by: Jesse Gross <jesse at nicira.com>
Acked-by: Andy Zhou <azhou at nicira.com>


commit 1362e248d68a8b7de3e6ec3689245e4dc882292b
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=1362e248d68a8b7de3e6ec3689245e4dc882292b
Author: Jesse Gross <jesse at nicira.com>
		
flow: Rename skb_mark to pkt_mark.
		
The skb_mark field is currently only available with the Linux datapath
and is only used internally. However, it is desirable to expose this
through OpenFlow and when it is exposed ideally it would not be system-
specific. In preparation for this, skb_mark is rename to pkt_mark in
internal data structures for consistency.

This does not rename the Linux interfaces because doing so would break
the API. It would not necessarily be desirable to do anyways since in
Linux-specific code it is clearer to use the actual name rather than a
generic one. This can lead to confusion in some places, however, because
we do not always strictly separate generic and platform dependent code
(one example is actions). This seems inevitable though at this point if
the lower and upper layers have different names (as they must given the
above requirements).

Signed-off-by: Jesse Gross <jesse at nicira.com>
Acked-by: Andy Zhou <azhou at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 NEWS                          |    3 +++
 include/openflow/nicira-ext.h |   17 +++++++++++++
 lib/dpif-netdev.c             |    6 ++---
 lib/flow.c                    |    5 ++--
 lib/flow.h                    |    3 ++-
 lib/match.c                   |   29 +++++++++++++++-------
 lib/match.h                   |    3 ++-
 lib/meta-flow.c               |   42 +++++++++++++++++---------------
 lib/meta-flow.h               |    2 +-
 lib/nx-match.c                |    4 ++++
 lib/odp-execute.c             |    2 +-
 lib/odp-util.c                |   22 ++++++++---------
 lib/odp-util.h                |    2 +-
 lib/ofp-print.c               |    4 ++++
 lib/ofp-util.c                |   15 ++++++++++--
 ofproto/ofproto-dpif-upcall.c |    2 +-
 ofproto/ofproto-dpif-xlate.c  |   39 ++++++------------------------
 ofproto/ofproto-dpif.c        |    2 +-
 ofproto/ofproto-unixctl.man   |    4 ++--
 ofproto/tunnel.c              |   53 +++++++++++++++++++++++++++++++++++++----
 ofproto/tunnel.h              |    5 ++--
 tests/ofproto-dpif.at         |   10 ++++----
 tests/ofproto.at              |    4 ++--
 tests/ovs-ofctl.at            |    8 ++++---
 utilities/ovs-ofctl.8.in      |    7 ++++++
 25 files changed, 189 insertions(+), 104 deletions(-)


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list