[ovs-git] Open vSwitch: netdev-vport: Manage ethernet addresses in userspace. (master)

dev at openvswitch.org dev at openvswitch.org
Fri Jan 4 01:33:03 UTC 2013


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  35b769cb491586718a72dc133509e96b0a2feee8 (commit)
       via  6f74491cda4414b746095314b36bca3e02b93840 (commit)
       via  df67d7ae92f98e18d2478162fc7850b11530f0c0 (commit)
       via  275707c33f8f5463154bc3e2f561181a2060ab57 (commit)
       via  9284baa2a4872f477722aa6fba2be8ad7b317f00 (commit)
       via  e09ee2592e39750190ef6eaaa8fe5d5e0135e2b0 (commit)
      from  6813ee7c06fbd2496fb73edd54a462a9053c6161 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 35b769cb491586718a72dc133509e96b0a2feee8
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=35b769cb491586718a72dc133509e96b0a2feee8
Author: Ethan Jackson <ethan at nicira.com>
		
netdev-vport: Manage ethernet addresses in userspace.
		
Letting netdev-vport manage ethernet addresses itself instead of
relying on the datapath has several advantages.  It simplifies the
code, is significantly more efficient, and will work when there is
no longer a one to one mapping from netdev-vports to datapath
vports.

Signed-off-by: Ethan Jackson <ethan at nicira.com>


commit 6f74491cda4414b746095314b36bca3e02b93840
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=6f74491cda4414b746095314b36bca3e02b93840
Author: Ethan Jackson <ethan at nicira.com>
		
vswitch: Remove PMTUD support from userspace.
		
This patch removes path MTU discovery from userspace.  The feature
still exists in the kernel where it will need to be removed in the
future.

Signed-off-by: Ethan Jackson <ethan at nicira.com>


commit df67d7ae92f98e18d2478162fc7850b11530f0c0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=df67d7ae92f98e18d2478162fc7850b11530f0c0
Author: Ethan Jackson <ethan at nicira.com>
		
netdev-vport: New helper netdev_vport_get_dev().
		
Signed-off-by: Ethan Jackson <ethan at nicira.com>


commit 275707c33f8f5463154bc3e2f561181a2060ab57
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=275707c33f8f5463154bc3e2f561181a2060ab57
Author: Ethan Jackson <ethan at nicira.com>
		
netdev: Rename get_drv_info() to get_status().
		
get_status() is a much more intuitive name since "status" is what
the database column is called.

Signed-off-by: Ethan Jackson <ethan at nicira.com>


commit 9284baa2a4872f477722aa6fba2be8ad7b317f00
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=9284baa2a4872f477722aa6fba2be8ad7b317f00
Author: Ethan Jackson <ethan at nicira.com>
		
netdev-vport: Fix theoretical null pointer dereference.
		
Theoretically, its possible for netdev_get_status() to be called
on a netdev-vport which hasn't had its configuration set yet.  In
this case, netdev-vport would dereference a null pointer.

Reported-by: Jesse Gross <jesse at nicira.com>
Signed-off-by: Ethan Jackson <ethan at nicira.com>


commit e09ee2592e39750190ef6eaaa8fe5d5e0135e2b0
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=e09ee2592e39750190ef6eaaa8fe5d5e0135e2b0
Author: Ethan Jackson <ethan at nicira.com>
		
ofproto-dpif: New function ofproto_receive().
		
Before translating a datapath flow key into actions, ofproto-dpif
must parse it, tweak it, and figure out what ofproto_dpif it
belongs to.  This patch brings all this logic into one place where
it will be easier to extend in the future.

Signed-off-by: Ethan Jackson <ethan at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 NEWS                   |    1 +
 lib/netdev-bsd.c       |    4 +-
 lib/netdev-dummy.c     |    4 +-
 lib/netdev-linux.c     |   57 ++++++++-----------
 lib/netdev-provider.h  |   10 ++--
 lib/netdev-vport.c     |  117 +++++++++++++-------------------------
 lib/netdev.c           |    8 +-
 lib/netdev.h           |    4 +-
 ofproto/ofproto-dpif.c |  147 ++++++++++++++++++++++++++----------------------
 vswitchd/bridge.c      |    4 +-
 vswitchd/vswitch.xml   |   12 ----
 11 files changed, 162 insertions(+), 206 deletions(-)


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list