[ovs-git] Open vSwitch: pinsched: Eliminate function callback in interface. (master)

dev at openvswitch.org dev at openvswitch.org
Wed Oct 23 15:41:37 UTC 2013


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  a6f7596183f8d3f629889c8c90b388556d48978e (commit)
       via  cfa955b083c5617212a29a03423e063ff6cb350a (commit)
       via  ee1afdd55567263f8a10f9bff3e5ae6fc8e42fdb (commit)
       via  d4fa4e792e55c60142f86a82822132ac584559ce (commit)
       via  22ee3544769ae9e9d35e8efa92b4b50468badf09 (commit)
       via  d38a3c7b8eb5d341c9e27b74b4a459dee284f770 (commit)
       via  f11c7538ba3d4d9fbaabd66457f1c20e95467b1c (commit)
       via  0fb7792ab3428a28044e53b443388cbc1231035a (commit)
      from  5b62d97786e4fea76aaa96ef0004465e8cb08cf8 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit a6f7596183f8d3f629889c8c90b388556d48978e
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=a6f7596183f8d3f629889c8c90b388556d48978e
Author: Ben Pfaff <blp at nicira.com>
		
pinsched: Eliminate function callback in interface.
		
I'm not a fan of function callbacks because I feel that they obscure
interfaces.  This eliminates the function callback used until now in
the pinsched code.

Signed-off-by: Ben Pfaff <blp at nicira.com>


commit cfa955b083c5617212a29a03423e063ff6cb350a
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=cfa955b083c5617212a29a03423e063ff6cb350a
Author: YAMAMOTO Takashi <yamamoto at valinux.co.jp>
		
connmgr: Fix packet-in reason for OpenFlow1.3 table-miss flow entries.
		
As per spec, make packet-in reason for OpenFlow1.3 table-miss flow
entries no_match rather than action.

Signed-off-by: YAMAMOTO Takashi <yamamoto at valinux.co.jp>
Signed-off-by: Ben Pfaff <blp at nicira.com>


commit ee1afdd55567263f8a10f9bff3e5ae6fc8e42fdb
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=ee1afdd55567263f8a10f9bff3e5ae6fc8e42fdb
Author: Ben Pfaff <blp at nicira.com>
		
fail-open: Add function to identify fail-open's flows.
		
This seems slightly cleaner than embedding this logic directing into
ofproto-dpif, since it is an interface that theoretically could be useful
to other ofproto providers.

Signed-off-by: Ben Pfaff <blp at nicira.com>


commit d4fa4e792e55c60142f86a82822132ac584559ce
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=d4fa4e792e55c60142f86a82822132ac584559ce
Author: Ben Pfaff <blp at nicira.com>
		
ofp-util: Use correct cookie value in "packet_in"s when no flow involved.
		
OpenFlow 1.3 uses all-1-bits in a packet_in to indicate that the packet_in
was not generated by a flow, but Open vSwitch incorrectly used 0.  This
fixes the problem.

For consistency, this commit also changes NXT_PACKET_IN to use all-1-bits
for this case, event though NXT_PACKET_IN was previously defined to use
zero.  This doesn't appear to make a difference for the NVP controller; if
it causes a problem for some other controller then I will revert that part
of the change.

Found by inspection.

Signed-off-by: Ben Pfaff <blp at nicira.com>


commit 22ee3544769ae9e9d35e8efa92b4b50468badf09
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=22ee3544769ae9e9d35e8efa92b4b50468badf09
Author: Ben Pfaff <blp at nicira.com>
		
ofp-util: Improve comments on struct ofputil_packet_in.
		
Signed-off-by: Ben Pfaff <blp at nicira.com>


commit d38a3c7b8eb5d341c9e27b74b4a459dee284f770
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=d38a3c7b8eb5d341c9e27b74b4a459dee284f770
Author: Ben Pfaff <blp at nicira.com>
		
connmgr: Move send_len from ofputil_packet_in to ofproto_packet_in.
		
send_len is not directly part of the OpenFlow packet_in message, at least
given that it is partially redundant with packet_len.  send_len is, rather,
a request to the connmgr that expresses how many bytes the action requested
be sent to the controller, but the connmgr cannot always honor it.

Signed-off-by: Ben Pfaff <blp at nicira.com>


commit f11c7538ba3d4d9fbaabd66457f1c20e95467b1c
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=f11c7538ba3d4d9fbaabd66457f1c20e95467b1c
Author: Ben Pfaff <blp at nicira.com>
		
connmgr: Move controller_id from ofputil_packet_in to ofproto_packet_in.
		
controller_id isn't part of the OpenFlow message, so it shouldn't be in
ofputil_packet_in.

Signed-off-by: Ben Pfaff <blp at nicira.com>


commit 0fb7792ab3428a28044e53b443388cbc1231035a
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=0fb7792ab3428a28044e53b443388cbc1231035a
Author: Ben Pfaff <blp at nicira.com>
		
ofproto, ofp-util: Begin disentangling packet-in wire format and handling.
		
struct ofputil_packet_in mixes data included in OpenFlow packet_in messages
with data that used internally by ofproto and connmgr to queue and route
packet_ins.  This commit begins disentangling these purposes by adding a
new struct ofproto_packet_in that wraps struct ofputil_packet_in.  Adding
this new level of indirection causes a lot of code churn, so this commit
mainly takes care of that to make the remaining changes easier to read.

This commit does move the list node used for queuing packet_ins into the
new wrapper structure.

Signed-off-by: Ben Pfaff <blp at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 OPENFLOW-1.1+                 |    3 --
 include/openflow/nicira-ext.h |    4 +-
 lib/ofp-print.c               |    2 +-
 lib/ofp-util.c                |   14 +++----
 lib/ofp-util.h                |   34 ++++++++++-----
 ofproto/connmgr.c             |   91 +++++++++++++++++++++++++++--------------
 ofproto/connmgr.h             |   19 +++++++--
 ofproto/fail-open.c           |   11 ++---
 ofproto/fail-open.h           |   12 +++++-
 ofproto/ofproto-dpif-upcall.c |   17 ++++----
 ofproto/ofproto-dpif-xlate.c  |   24 ++++++-----
 ofproto/ofproto-dpif.c        |   22 ++++++----
 ofproto/ofproto-dpif.h        |    6 ++-
 ofproto/ofproto-provider.h    |   12 ++++++
 ofproto/pinsched.c            |   15 ++++---
 ofproto/pinsched.h            |    8 ++--
 tests/ofproto-dpif.at         |    2 +-
 17 files changed, 192 insertions(+), 104 deletions(-)


hooks/post-receive
-- 
Open vSwitch



More information about the git mailing list