[ovs-git] [openvswitch/ovs] bc36fc: datapath: Replace rcu_dereference() with rcu_acces...

GitHub noreply at github.com
Fri Sep 12 21:42:47 UTC 2014


  Branch: refs/heads/master
  Home:   https://github.com/openvswitch/ovs
  Commit: bc36fcd3d39a674262a3ea632c29b9f2ea7a7415
      https://github.com/openvswitch/ovs/commit/bc36fcd3d39a674262a3ea632c29b9f2ea7a7415
  Author: Andreea-Cristina Bernat <bernat.ada at gmail.com>
  Date:   2014-09-12 (Fri, 12 Sep 2014)

  Changed paths:
    M datapath/flow.c
    M datapath/linux/compat/include/linux/rcupdate.h

  Log Message:
  -----------
  datapath: Replace rcu_dereference() with rcu_access_pointer()

The "rcu_dereference()" call is used directly in a condition.
Since its return value is never dereferenced it is recommended to use
"rcu_access_pointer()" instead of "rcu_dereference()".
Therefore, this patch makes the replacement.

The following Coccinelle semantic patch was used:
@@
@@

(
 if(
 (<+...
- rcu_dereference
+ rcu_access_pointer
  (...)
  ...+>)) {...}
|
 while(
 (<+...
- rcu_dereference
+ rcu_access_pointer
  (...)
  ...+>)) {...}
)

Signed-off-by: Andreea-Cristina Bernat <bernat.ada at gmail.com>
Signed-off-by: David S. Miller <davem at davemloft.net>
Acked-by: Pravin B Shelar <pshelar at nicira.com>


  Commit: 49f24f6dc62eebef2d68f265400c8989dcfdf097
      https://github.com/openvswitch/ovs/commit/49f24f6dc62eebef2d68f265400c8989dcfdf097
  Author: Jean Sacren <sakiwit at gmail.com>
  Date:   2014-09-12 (Fri, 12 Sep 2014)

  Changed paths:
    M datapath/datapath.c

  Log Message:
  -----------
  datapath: fix duplicate #include headers

The #include headers net/genetlink.h and linux/genetlink.h both were
included twice, so delete each of the duplicate.

Signed-off-by: Jean Sacren <sakiwit at gmail.com>
Cc: Pravin Shelar <pshelar at nicira.com>
Cc: dev at openvswitch.org
Signed-off-by: David S. Miller <davem at davemloft.net>
Acked-by: Pravin B Shelar <pshelar at nicira.com>


  Commit: a6ddcc9a1b1779b606896e37e2e3187195adfe9f
      https://github.com/openvswitch/ovs/commit/a6ddcc9a1b1779b606896e37e2e3187195adfe9f
  Author: Himangi Saraogi <himangi774 at gmail.com>
  Date:   2014-09-12 (Fri, 12 Sep 2014)

  Changed paths:
    M datapath/datapath.c

  Log Message:
  -----------
  datapath: Use IS_ERR_OR_NULL

This patch introduces the use of the macro IS_ERR_OR_NULL in place of
tests for NULL and IS_ERR.

The following Coccinelle semantic patch was used for making the change:

@@
expression e;
@@

- e == NULL || IS_ERR(e)
+ IS_ERR_OR_NULL(e)
 || ...

Signed-off-by: Himangi Saraogi <himangi774 at gmail.com>
Acked-by: Julia Lawall <julia.lawall at lip6.fr>
Acked-by: Pravin B Shelar <pshelar at nicira.com>
Signed-off-by: David S. Miller <davem at davemloft.net>


  Commit: 08fb1bbdcc9f63478fc96c732fb7a447c4f628f7
      https://github.com/openvswitch/ovs/commit/08fb1bbdcc9f63478fc96c732fb7a447c4f628f7
  Author: WANG Cong <xiyou.wangcong at gmail.com>
  Date:   2014-09-12 (Fri, 12 Sep 2014)

  Changed paths:
    M datapath/datapath.c
    M datapath/linux/compat/include/linux/netdevice.h
    M datapath/vport.c

  Log Message:
  -----------
  datapath: introduce netdev_alloc_pcpu_stats() for drivers

There are many drivers calling alloc_percpu() to allocate pcpu stats
and then initializing ->syncp. So just introduce a helper function for them.

Cc: David S. Miller <davem at davemloft.net>
Signed-off-by: Cong Wang <xiyou.wangcong at gmail.com>
Signed-off-by: David S. Miller <davem at davemloft.net>
Acked-by: Pravin B Shelar <pshelar at nicira.com>


  Commit: b81deb156df3ec7289b0a8a69a46d3075826296c
      https://github.com/openvswitch/ovs/commit/b81deb156df3ec7289b0a8a69a46d3075826296c
  Author: WANG Cong <xiyou.wangcong at gmail.com>
  Date:   2014-09-12 (Fri, 12 Sep 2014)

  Changed paths:
    M datapath/datapath.c
    M datapath/datapath.h

  Log Message:
  -----------
  openvswitch: rename ->sync to ->syncp

Openvswitch defines u64_stats_sync as ->sync rather than ->syncp,
so fails to compile with netdev_alloc_pcpu_stats(). So just rename it to ->syncp.

Reported-by: kbuild test robot <fengguang.wu at intel.com>
Fixes: 1c213bd24ad04f4430031 (net: introduce netdev_alloc_pcpu_stats() for drivers)
Cc: David S. Miller <davem at davemloft.net>
Signed-off-by: Cong Wang <xiyou.wangcong at gmail.com>
Reviewed-by: Flavio Leitner <fbl at redhat.com>
Signed-off-by: David S. Miller <davem at davemloft.net>
Acked-by: Pravin B Shelar <pshelar at nicira.com>


Compare: https://github.com/openvswitch/ovs/compare/f00fa8cbad76...b81deb156df3


More information about the git mailing list