[ovs-git] [openvswitch/ovs] 78145f: dpif: Always generate RFC4122 UUIDs for UFID.

GitHub noreply at github.com
Wed Jun 10 01:36:32 UTC 2015


  Branch: refs/heads/master
  Home:   https://github.com/openvswitch/ovs
  Commit: 78145f6edb62f6d6ec3a99f506dff3d617456f9a
      https://github.com/openvswitch/ovs/commit/78145f6edb62f6d6ec3a99f506dff3d617456f9a
  Author: Joe Stringer <joestringer at nicira.com>
  Date:   2015-06-09 (Tue, 09 Jun 2015)

  Changed paths:
    M lib/dpif.c
    M lib/uuid.c
    M lib/uuid.h

  Log Message:
  -----------
  dpif: Always generate RFC4122 UUIDs for UFID.

This patch sacrifices a few bits of hash quality from the 128-bit unique
flow identifiers to make the UFIDs RFC4122-conformant as per the version 4
(random) UUID spec. Given that the 128-bit space is already quite large,
this should not affect the spread of UFIDs in any meaningful way for
hashing.

Signed-off-by: Joe Stringer <joestringer at nicira.com>
Acked-by: Ben Pfaff <blp at nicira.com>


  Commit: 10e92b4f7a1db4bd88452cdc3aaec5fd46c4f7fe
      https://github.com/openvswitch/ovs/commit/10e92b4f7a1db4bd88452cdc3aaec5fd46c4f7fe
  Author: Joe Stringer <joestringer at nicira.com>
  Date:   2015-06-09 (Tue, 09 Jun 2015)

  Changed paths:
    M lib/odp-util.c
    M tests/dpif-netdev.at
    M tests/ofproto-dpif.at
    M tests/ofproto-macros.at

  Log Message:
  -----------
  odp-util: Reuse UUID marshalling for UFID.

Unique flow identifiers are really a UUID of sorts, so it makes sense to
reuse the UUID string representations for UFID.

Suggested-by: Ben Pfaff <blp at nicira.com>
Signed-off-by: Joe Stringer <joestringer at nicira.com>
Acked-by: Ben Pfaff <blp at nicira.com>


  Commit: bdd7ecf5bfc4a255872aa60057b3b96f72b47d8a
      https://github.com/openvswitch/ovs/commit/bdd7ecf5bfc4a255872aa60057b3b96f72b47d8a
  Author: Joe Stringer <joestringer at nicira.com>
  Date:   2015-06-09 (Tue, 09 Jun 2015)

  Changed paths:
    M include/openvswitch/types.h
    M lib/dpif-netdev.c
    M lib/dpif.c
    M lib/util.h
    M ofproto/ofproto-dpif-upcall.c
    M tests/test-hash.c

  Log Message:
  -----------
  types: Rename and move ovs_u128_equal().

This function doesn't need to be exported in the public OVS headers, and
it had an inconsistent name compared to uuid_equals(). Rename and move.

Signed-off-by: Joe Stringer <joestringer at nicira.com>
Acked-by: Ben Pfaff <blp at nicira.com>


Compare: https://github.com/openvswitch/ovs/compare/19ba142220fb...bdd7ecf5bfc4


More information about the git mailing list