[ovs-git] [openvswitch/ovs] 3eb142: ovsdb-idl: Avoid class declaration.

GitHub noreply at github.com
Tue Aug 15 21:57:21 UTC 2017


  Branch: refs/heads/master
  Home:   https://github.com/openvswitch/ovs
  Commit: 3eb142335321b16c255e8fc8ba57d13ea74dd20c
      https://github.com/openvswitch/ovs/commit/3eb142335321b16c255e8fc8ba57d13ea74dd20c
  Author: Joe Stringer <joe at ovn.org>
  Date:   2017-08-15 (Tue, 15 Aug 2017)

  Changed paths:
    M lib/db-ctl-base.c
    M lib/ovsdb-idl-provider.h
    M lib/ovsdb-idl.c
    M ovsdb/ovsdb-idlc.in

  Log Message:
  -----------
  ovsdb-idl: Avoid class declaration.

In C++, 'class' is a keyword. If this is used as the name for a field,
then C++ compilers can get confused about the context and fail to
compile references to such fields. Rename the field to 'class_' to
avoid this issue.

Signed-off-by: Joe Stringer <joe at ovn.org>
Acked-by: Ben Pfaff <blp at ovn.org>


  Commit: c6e5d064a4f37a66ca6220ee9dd2bfa48035c103
      https://github.com/openvswitch/ovs/commit/c6e5d064a4f37a66ca6220ee9dd2bfa48035c103
  Author: Joe Stringer <joe at ovn.org>
  Date:   2017-08-15 (Tue, 15 Aug 2017)

  Changed paths:
    M lib/ovsdb-idl-provider.h
    M lib/ovsdb-idl.c
    M ovsdb/ovsdb-idlc.in

  Log Message:
  -----------
  ovsdb-idl: Avoid mutable type specifier.

In C++, 'mutable' is a keyword. If this is used as the name for a field,
then C++ compilers can get confused about the context and fail to
compile references to such fields. Rename the field to 'is_mutable' to
avoid this issue.

Signed-off-by: Joe Stringer <joe at ovn.org>
Acked-by: Ben Pfaff <blp at ovn.org>


  Commit: fa50ab0bfbbb63e37813c33613b8c61536314253
      https://github.com/openvswitch/ovs/commit/fa50ab0bfbbb63e37813c33613b8c61536314253
  Author: Joe Stringer <joe at ovn.org>
  Date:   2017-08-15 (Tue, 15 Aug 2017)

  Changed paths:
    M lib/ovsdb-data.h
    M lib/ovsdb-idl-provider.h
    M lib/ovsdb-idl.c

  Log Message:
  -----------
  ovsdb-idl: Avoid new expression.

In C++, 'new' is a keyword. If this is used as the name for a field,
then C++ compilers can get confused about the context and fail to
compile references to such fields. Rename the field to 'new_datum' to
avoid this issue.

Signed-off-by: Joe Stringer <joe at ovn.org>
Acked-by: Ben Pfaff <blp at ovn.org>


  Commit: 4e0b4acca2ab294a07836684d0726187b3cf7174
      https://github.com/openvswitch/ovs/commit/4e0b4acca2ab294a07836684d0726187b3cf7174
  Author: Joe Stringer <joe at ovn.org>
  Date:   2017-08-15 (Tue, 15 Aug 2017)

  Changed paths:
    M lib/ovsdb-data.h
    M lib/ovsdb-idl-provider.h
    M lib/ovsdb-idl.c

  Log Message:
  -----------
  ovsdb-idl: Rename 'old' to 'old_datum'.

Now that the 'new' datum is named 'new_datum', be more consistent by
renaming 'old' to 'old_datum' to match.

Signed-off-by: Joe Stringer <joe at ovn.org>
Acked-by: Ben Pfaff <blp at ovn.org>


Compare: https://github.com/openvswitch/ovs/compare/f26984074376...4e0b4acca2ab


More information about the git mailing list