[ovs-git] [openvswitch/ovs] b6b260: netdev-dpdk: fix management of pre-existing mempoo...

GitHub noreply at github.com
Fri Oct 27 17:57:24 UTC 2017


  Branch: refs/heads/master
  Home:   https://github.com/openvswitch/ovs
  Commit: b6b26021d2e23f8f41dc4114d268a50391effe87
      https://github.com/openvswitch/ovs/commit/b6b26021d2e23f8f41dc4114d268a50391effe87
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  netdev-dpdk: fix management of pre-existing mempools.

Fix an issue on reconfiguration of pre-existing mempools.
This patch avoids to call dpdk_mp_put() - and erroneously
release the mempool - when it already exists.

CC: Mark B Kavanagh <mark.b.kavanagh at intel.com>
CC: Aaron Conole <aconole at redhat.com>
CC: Darrell Ball <dlu998 at gmail.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Reported-by: Ciara Loftus <ciara.loftus at intel.com>
Tested-by: Ciara Loftus <ciara.loftus at intel.com>
Reported-by: Róbert Mulik <robert.mulik at ericsson.com>
Fixes: d555d9bded5f ("netdev-dpdk: Create separate memory pool for each port.")
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Acked-by: Mark Kavanagh <mark.b.kavanagh at intel.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: f06546a51dd8d17124e888953c464e5fa13a6a12
      https://github.com/openvswitch/ovs/commit/f06546a51dd8d17124e888953c464e5fa13a6a12
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  Fix mempool names to reflect socket id.

Create mempool names by considering also the NUMA socket number.
So a name reflects what socket the mempool is allocated on.
This change is needed for the NUMA-awareness feature.

CC: Mark B Kavanagh <mark.b.kavanagh at intel.com>
CC: Aaron Conole <aconole at redhat.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Reported-by: Ciara Loftus <ciara.loftus at intel.com>
Tested-by: Ciara Loftus <ciara.loftus at intel.com>
Fixes: d555d9bded5f ("netdev-dpdk: Create separate memory pool for each port.")
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: 837c1761be09263d5337680722c6e67cfc58a370
      https://github.com/openvswitch/ovs/commit/837c1761be09263d5337680722c6e67cfc58a370
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  netdev-dpdk: skip init for existing mempools.

Skip initialization of mempool packet areas if this was already
done in a previous call to dpdk_mp_create.

CC: Darrell Ball <dlu998 at gmail.com>
CC: Ciara Loftus <ciara.loftus at intel.com>
CC: Aaron Conole <aconole at redhat.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Acked-by: Mark Kavanagh <mark.b.kavanagh at intel.com>
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: 65056fd796947adb91a6b614e7791ba789206cf3
      https://github.com/openvswitch/ovs/commit/65056fd796947adb91a6b614e7791ba789206cf3
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  netdev-dpdk: manage failure in mempool name creation.

In case a mempool name could not be generated log a message
and return a null mempool pointer to the caller.

CC: Mark B Kavanagh <mark.b.kavanagh at intel.com>
CC: Darrell Ball <dlu998 at gmail.com>
CC: Ciara Loftus <ciara.loftus at intel.com>
CC: Kevin Traynor <ktraynor at redhat.com>
CC: Aaron Conole <aconole at redhat.com>
Fixes: d555d9bded5f ("netdev-dpdk: Create separate memory pool for each port.")
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: ad9b5b9bc78eebb5b60cbe740fdf8e8645650cfb
      https://github.com/openvswitch/ovs/commit/ad9b5b9bc78eebb5b60cbe740fdf8e8645650cfb
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  netdev-dpdk: Reword mp_size as n_mbufs.

For code readability purposes mp_size is renamed as n_mbufs
in dpdk_mp structure.
This parameter is passed to rte mempool creation functions
and is meant to contain the number of elements inside
the requested mempool.

CC: Ciara Loftus <ciara.loftus at intel.com>
CC: Aaron Conole <aconole at redhat.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Acked-by: Mark Kavanagh <mark.b.kavanagh at intel.com>
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: a08a115d26b383369b751f897803b6ac741afd18
      https://github.com/openvswitch/ovs/commit/a08a115d26b383369b751f897803b6ac741afd18
  Author: antonio.fischetti at intel.com <antonio.fischetti at intel.com>
  Date:   2017-10-26 (Thu, 26 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.

For readability purposes dpdk_mp_put is renamed as dpdk_mp_free.

CC: Mark B Kavanagh <mark.b.kavanagh at intel.com>
CC: Darrell Ball <dlu998 at gmail.com>
CC: Ciara Loftus <ciara.loftus at intel.com>
CC: Kevin Traynor <ktraynor at redhat.com>
CC: Aaron Conole <aconole at redhat.com>
Signed-off-by: Antonio Fischetti <antonio.fischetti at intel.com>
Acked-by: Mark Kavanagh <mark.b.kavanagh at intel.com>
Acked-by: Kevin Traynor <ktraynor at redhat.com>
Signed-off-by: Ian Stokes <ian.stokes at intel.com>


  Commit: a05df205cdeb09ae644968f610365223f9b991ba
      https://github.com/openvswitch/ovs/commit/a05df205cdeb09ae644968f610365223f9b991ba
  Author: Ben Pfaff <blp at ovn.org>
  Date:   2017-10-27 (Fri, 27 Oct 2017)

  Changed paths:
    M lib/netdev-dpdk.c

  Log Message:
  -----------
  Merge branch 'dpdk_merge' of https://github.com/istokes/ovs into HEAD

This patchset specifically deals with fixing a bug related to mempool
management for DPDK and vhost ports.

Patchset has been reviewed and Acked by a number of trusted contributors.

Patchset has been validated follows:

Clang/Sparse compilation and analysis.
OVS Unit tests
Vsperf Performance tests for OVS DPDK for p2p, pvp, pvvp,pvpv
Vpserf integration tests for OVS DPDK for p2p, pvp, pvvp.
MTU tests for both physical and vhost DPDK port types.
Multi queue for DPDK and vhost port types with both kernel virtio and DPDK
virtio interfaces in the guest.

Signed-off-by: Ben Pfaff <blp at ovn.org>


Compare: https://github.com/openvswitch/ovs/compare/bf168c45b90a...a05df205cdeb


More information about the git mailing list